Skip to Main Content

Can't open Port( reverse ssh port forwarding)

User_5LEKRNov 22 2022

Hello, i have a problem with not being able to open a port on my OCI
my setup: i have a server on my local network running PVE, couple lxc containers..
i host couple services now just for local use but i would like to open it for public/also learn self hosting as i am an IT student
the network is behind a NAT/CGNAT i don't know specificly and this isn't that much important as
i will use reverse ssh port forwarding
connections go like this:
container game server (port 25565 udp and tcp too) (ip:
container has my ssh keys, manages port forwarding with the following command: ssh -nNTv -R opc@<my OCI server ip> -i /this-is/where-is/my/ssh.key
i removed private stuff from it, if i run this it successfully forwards port back to
3.OCI intance: included photos
ssh-forwarding-to-oracle.pngingress-rules-oracle.pngbut when i check if the required ports are open i got this
oracle-localports-opened-closed.pngso while on localhost its oppened the ports on the network controller side not
the software firewall config:
[opc@instance-20220929-2044 ~]$ sudo iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination
Chain FORWARD (policy ACCEPT)
target prot opt source destination
Chain OUTPUT (policy ACCEPT)
target prot opt source destination
BareMetalInstanceServices all -- anywhere

this isn't all of it i haven't posted the "Chain BareMetalInstanceServices (1 references)" section, i might leak private information
i haven't worked with iptables before so if the problem is just a command here, i am realy sorry but i couldn't figure out

could someone please help how can i solve this?, so i can access the services i host locally

Post Details
Added on Nov 22 2022