Skip to Main Content

After changing port (1521 to 1525 in listener.ora & tnsnames.ora), OEM: the database is down

User_AAD34Aug 27 2015 — edited Sep 3 2015

Hi,

I'm installing Oracle Database 11gR2 (11.2.0.4) on Oracle Linux 7.1.

To be short, what i'm trying to do now is changing the default port from 1521 to 1525.

So i stopped the listener (lsnrctl stop), then changed my listener.ora & tnsnames.ora :

listener.ora

# listener.ora Network Configuration File: /u01/app/oracle/product/11.2.0/dbhome_1/network/admin/listener.ora

# Generated by Oracle configuration tools.

LISTENER =

  (DESCRIPTION_LIST =

    (DESCRIPTION =

      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))

    )

    (DESCRIPTION =

      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1525))

    )

  )

ADR_BASE_LISTENER = /u01/app/oracle

tnsnames.ora

# tnsnames.ora Network Configuration File: /u01/app/oracle/product/11.2.0/dbhome_1/network/admin/tnsnames.ora

# Generated by Oracle configuration tools.

BI =

  (DESCRIPTION =

    (ADDRESS_LIST =

      (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1525))

    )

    (CONNECT_DATA =

      (SERVER = DEDICATED)

      (SERVICE_NAME = bi)

    )

  )

And then, altered the local_listener:

SQL > ALTER SYSTEM SET LOCAL_LISTENER = "(ADDRESS=(PROTOCOL=TCP)(HOST=localhost)(PORT=1525))";

SQL > ALTER SYSTEM REGISTER;

Lastly, i started the listener again (lsnrctl start).

Next, i tried to connect using Oracle SQL Developer from the client. The port 1525 works perfectly fine.

The problem is, when i opened the OEM (Oracle Enterprise Manager), it says: "The database is down. Please specify the host credentials to access database restart and diagnostics tools", which is like this: http://imgur.com/oKLPW65

So i logged into the host account, and it shows that the database instance, listener, and agent is all down. like this: http://imgur.com/Bzr84bz

it looks like the port used by OEM is still 1521.

What should i do? Anyone can help me solve the problem?

Thanks in advance.

****UPDATE:

After changing the emoms.properties & the targets.xml (thanks to egar), you will need to re-configure dbconsole using emca.

so what i do is dropping the config:

$ emca -deconfig dbcontrol db -repos drop

and then create again:

$ emca -config dbcontrol db -repos create

Voila.

Best Regards,

Jerry Antonius

Comments
Post Details
Added on Aug 27 2015
9 comments
982 views